<!DOCTYPE html>
<html>
  <head>
     
	<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <script> (adsbygoogle = window.adsbygoogle || []).push({ google_ad_client: "ca-pub-8258904172299765", enable_page_level_ads: true }); </script>
     <meta charset="utf-8">
<title>Часто задаваемые вопросы / F.A.Q &raquo; Sergei Strelec</title>
<meta name="description" content="Часто задаваемые вопросы">
<meta name="keywords" content="class, spoiler, pmagic, javascript, closedspan, spana, color, style, linux, сборки, можно, initrd, Windows, Strelec, target, образ, Sergei, Parted_Magic, language, каталог">
<meta name="generator" content="DataLife Engine (http://dle-news.ru)">
<meta property="og:site_name" content="Sergei Strelec">
<meta property="og:type" content="article">
<meta property="og:title" content="Часто задаваемые вопросы / F.A.Q">
<meta property="og:url" content="https://sergeistrelec.ru/faq.html">
<meta property="og:image" content="http://www.sergeistrelec.ru/uploads/faq/root_dir.png">
<meta property="og:description" content="*  margin: 0; padding: 0;  .faq-container  color: #404040; /*font-family: Arial, sans-serif;*/ font-size: 100%; height: 100%; line-height: 175%; margin: 0 16px; position: relative; ">
<link rel="search" type="application/opensearchdescription+xml" href="https://sergeistrelec.ru/index.php?do=opensearch" title="Sergei Strelec">
<link rel="canonical" href="https://sergeistrelec.ru/faq.html">
<link rel="alternate" type="application/rss+xml" title="Sergei Strelec" href="https://sergeistrelec.ru/rss.xml">
<link href="/engine/classes/min/index.php?f=engine/editor/css/default.css&amp;v=0c210" rel="stylesheet" type="text/css">
<script src="/engine/classes/min/index.php?g=general&amp;v=0c210"></script>
<script src="/engine/classes/min/index.php?f=engine/classes/js/jqueryui.js,engine/classes/js/dle_js.js,engine/classes/highlight/highlight.code.js&amp;v=0c210" defer></script>
    <meta http-equiv="X-UA-Compatible" content="IE=edge">
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
    <link rel="stylesheet" href="/newyear/style.css">
	<link rel="stylesheet" href="/templates/sstr/style/engine.css" type="text/css" media="screen, projection" />
    <link rel="stylesheet" href="/templates/sstr/style/main.css" type="text/css" media="screen, projection" />
    <link rel="shortcut icon" href="/templates/sstr/images/favicon.ico" />
    <script src="/newyear/script.js" defer></script>
	<!--[if IE 9]>
    <link rel="stylesheet" href="/templates/sstr/style/ie9.css" type="text/css" media="screen, projection">
    <![endif]-->
    <!--[if lte IE 9]>
    <link rel="stylesheet" href="/templates/sstr/style/ie7.css" type="text/css" media="screen, projection">
    <script type="text/javascript" src="/templates/sstr/oldies/oldies.js"></script>
    <![endif]--> 
     <link rel="stylesheet" type="text/css" href="//cdnjs.cloudflare.com/ajax/libs/cookieconsent2/3.1.0/cookieconsent.min.css" />
<script src="//cdnjs.cloudflare.com/ajax/libs/cookieconsent2/3.1.0/cookieconsent.min.js"></script>
<script>
window.addEventListener("load", function(){
window.cookieconsent.initialise({
  "palette": {
    "popup": {
      "background": "#237afc"
    },
    "button": {
      "background": "#fff",
      "text": "#237afc"
    }
  },
  "content": {
    "message": "На сайте используются файлы cookie, чтобы сделать ваше посещение более удобным.\nThis website uses cookies to ensure you get the best experience on our website.",
    "dismiss": "Понял/Got it!",
    "link": "Learn more",
    "href": "https://sergeistrelec.ru/privacy_policy.html"
  }
})});
</script>
     </head>
  <body>
     <div id="loading-layer" style="display:none;font-family: verdana;font-size: 11px;width:200px;height:50px;background:#fff;padding:10px;text-align:center;border:1px solid #000">
      <div style="font-weight:bold" id="loading-layer-text">Загрузка. Пожалуйста, подождите...</div>
      <br /><img src="engine/ajax/loading.gif" alt="" />
    </div>
    <div id="busy_layer" style="visibility: hidden; display: block; position: absolute; left: 0px; top: 0px; width: 100%; height: 100%; background-color: gray; opacity: 0.1; -ms-filter: 'progid:dximagetransform.microsoft.alpha(opacity=10)'; filter:progid:dximagetransform.microsoft.alpha(opacity=10); "></div>
    <script>
<!--
var dle_root       = '/';
var dle_admin      = '';
var dle_login_hash = '4ca38ce2e169bdf9f6717b41f45098043ce92094';
var dle_group      = 5;
var dle_skin       = 'sstr';
var dle_wysiwyg    = '0';
var quick_wysiwyg  = '0';
var dle_min_search = '4';
var dle_act_lang   = ["Да", "Нет", "Ввод", "Отмена", "Сохранить", "Удалить", "Загрузка. Пожалуйста, подождите..."];
var menu_short     = 'Быстрое редактирование';
var menu_full      = 'Полное редактирование';
var menu_profile   = 'Просмотр профиля';
var menu_send      = 'Отправить сообщение';
var menu_uedit     = 'Админцентр';
var dle_info       = 'Информация';
var dle_confirm    = 'Подтверждение';
var dle_prompt     = 'Ввод информации';
var dle_req_field  = 'Заполните все необходимые поля';
var dle_del_agree  = 'Вы действительно хотите удалить? Данное действие невозможно будет отменить';
var dle_spam_agree = 'Вы действительно хотите отметить пользователя как спамера? Это приведёт к удалению всех его комментариев';
var dle_c_title    = 'Отправка жалобы';
var dle_complaint  = 'Укажите текст Вашей жалобы для администрации:';
var dle_mail       = 'Ваш e-mail:';
var dle_big_text   = 'Выделен слишком большой участок текста.';
var dle_orfo_title = 'Укажите комментарий для администрации к найденной ошибке на странице:';
var dle_p_send     = 'Отправить';
var dle_p_send_ok  = 'Уведомление успешно отправлено';
var dle_save_ok    = 'Изменения успешно сохранены. Обновить страницу?';
var dle_reply_title= 'Ответ на комментарий';
var dle_tree_comm  = '0';
var dle_del_news   = 'Удалить статью';
var dle_sub_agree  = 'Вы действительно хотите подписаться на комментарии к данной публикации?';
var dle_captcha_type  = '1';
var DLEPlayerLang     = {prev: 'Предыдущий',next: 'Следующий',play: 'Воспроизвести',pause: 'Пауза',mute: 'Выключить звук', unmute: 'Включить звук', settings: 'Настройки', enterFullscreen: 'На полный экран', exitFullscreen: 'Выключить полноэкранный режим', speed: 'Скорость', normal: 'Обычная', quality: 'Качество', pip: 'Режим PiP'};
var allow_dle_delete_news   = false;

jQuery(function($){
$('pre code').each(function(i, e) {hljs.highlightBlock(e, null)});
});
//-->
</script>
	
    <div id="wrapper">
      <div id="header">
        <!-- HEADER -->
        <div class="h1">
          <div class="h2">
            <div class="h3">
              <div class="h4">
                <div class="h5">
                  <a href="/" class="h6">sergeistrelec.ru - Загрузочные диски</a>
                  <div class="h7">
                    <div class="log3">
                      

<div class="log5">
   <a href="/index.php?do=register" class="log4">Создать аккаунт</a>
    <form method="post" onsubmit="javascript:showBusyLayer()" action=''>
      <input name="login" type="hidden" id="login" value="submit" />
      <div class="log1">
         <input name="login_name" type="text" class="log_input1" value="Логин" onblur="if(this.value=='') this.value='Логин';" onfocus="if(this.value=='Логин') this.value='';" />
         <input name="login_password" type="password" class="log_input2" value="*******" onblur="if(this.value=='') this.value='*******';" onfocus="if(this.value=='*******') this.value='';" />
         <input onclick="submit();" name="image" type="image" src="/templates/sstr/images/spacer.gif" class="log_btn" alt="" />
      </div>
      <a href="/index.php?do=lostpassword" class="log6">Забыли пароль?</a>
   </form>
</div>
 
                    </div>
                  </div>
                </div>
              </div>
            </div>
          </div>
        </div>
        <div class="h8">
          <div class="h9">
            <ul>
              <li><span><a href="/">Главная / Home</a></span></li>
              <li><span><a href="/rules.html">Правила</a></span></li>
              <li><span><a href="/faq.html">F.A.Q</a></span></li>
              <li><span><a href="/index.php?do=feedback">Контакты / Contacts</a></span></li>
              <li><span><a href="/info_site.html">О сайте / About</a></span></li>
              <li><span><a href="/index.php?action=mobile">Мобильная версия</a></span></li>
              <li><span><a href="/rss.xml">RSS</a></span></li>
              <li><span><a href="/donate.html">Поддержите проект / Donate</a></span></li>
            </ul>
            <form onsubmit="javascript: showbusylayer()" method="post" action=''>
              <input type="hidden" name="do" value="search" />
              <input type="hidden" name="subaction" value="search" />
              <input name="story" type="text" class="ser1" value="Введите слова для поиска ..." onblur="if(this.value=='') this.value='Введите слова для поиска ...';" onfocus="if(this.value=='Введите слова для поиска ...') this.value='';" />
              <input type="image" class="ser2" src="/templates/sstr/images/spacer.gif" alt="search" />
            </form>
          </div>
        </div>
        <!-- /HEADER -->
      </div>
      <div id="container">
        <div class="cn1">
          <div class="cn2">
            <div class="cn3">
              <div class="cn4">
                <div class="cn5">
                  <div class="cn6">
                    <!-- LEFT -->
                    <div id="left">
                      <div class="bl0">
                        <div class="bl1">
                          <div class="bl2">
                            <div class="bl3">Категории новостей</div>
                            <ul class="bln">
                              <li><a href="/winpe_10_8/">WinPE 10-8 Sergei Strelec (RUS)</a></li>
                              <li><a href="/version_history.html">История версий (RUS)</a></li>
                              <li><a href="/winpe-10-8-sergei-strelec-english/">WinPE 10-8 Sergei Strelec (ENG)</a></li>
                              <li><a href="/version_history_en.html">Version history (ENG)</a></li>
                              <li><a href="/winpe_10/">WinPE 10 Sergei Strelec</a></li>
                              <li><a href="/faq.html">Часто задаваемые вопросы</a></li>
                              <li><a href="/system/">Обслуживание системы</a></li>
                              <li><a href="/bootable_flash/">Загрузочные флешки</a></li>
                              <li><a href="/boot_disks/">Загрузочные диски</a></li>
                              <li><a href="/article/">Статьи</a></li>
                              <li><a href="/video_tutorials/">Видеоуроки</a></li>
                              <li><a href="/raznoe/">Разное</a></li>
                              <li><a href="/rss.xml">Подписаться на новости</a></li>
                              <li><a href="/paid_services.html">WinPE под заказ</a></li>  
                            </ul>
                          </div>
                        </div>
                      </div>
                      <div class="bl0">
                        <div class="bl1">
                          <div class="bl2">
                            <div class="bl3">Опрос</div>
                            
                          </div>
                        </div>
                      </div>
                      <div class="bl0">
                        <div class="bl1">
                          <div class="bl2">
                            <div class="bl3">Google реклама</div>
                            
                          </div>
                        </div>
                      </div>
                      <div class="bl0">
                        <div class="bl1">
                          <div class="bl2">
                            <div class="bl3">Ремонт и обслуживание в Израиле</div>
                            <center><a href="https://xboy16.wixsite.com/boris-computers"><img src="//sergeistrelec.ru/uploads/screenshot/borya.jpg" alt="" /></a></center>
                          </div>
                        </div>
                      </div>
                      <div class="bl0">
                        <div class="bl1">
                          <div class="bl2">
                            <div class="bl3">Bitcoin Trading/Tорговля</div>
                            <div align="center"><a href="https://cex.io/r/0/up101977637/0/" target="_blank"><img src="https://cex.io/rb/CEX-1-250x250.png" alt="Buy Bitcoins with Credit Card" width="250" height="250" border="0"></a></div>
                          </div>
                        </div>
                      </div>
                      <div class="bl0">
                        <div class="bl1">
                          <div class="bl2">
                           <div class="bl3">Play Freebitcoin</div>
                           <div align="center"><a href="https://freebitco.in/?r=8675661"><img src="/templates/sstr/images/freebitco.jpg" alt="" /></a></div> 
                           </div>
                        </div>
                      </div>
                      <div class="bl0">
                        <div class="bl1">
                          <div class="bl2">
                            <div class="bl3">Предложение</div>
                            <div align="center"><div class="ads-100"><a href="https://sergeistrelec.ru/index.php?do=feedback" target="_blank"><img src="/uploads/screenshot/commercial.jpg" style="border: none;" alt="" /></a></div></div>
                           </div>
                        </div>
                      </div>
                    </div>
                    <!-- /LEFT -->
                    <!-- RIGHT -->
                    <div id="right">
                      <div class="bl0">
                        <div class="bl1">
                          <div class="bl2">
                            <div class="bl3">Поддержите сайт / Donate</div>
                            <div align="center">
      <a href="/donate.html" rel="nofollow" target="_blank" alt="Помощь проекту">
         <center><img src="//sergeistrelec.ru/uploads/screenshot/donate.png" alt="Помощь проекту" title="Помощь проекту" /></center>
      </a>
</div>                                         
                          </div>
                        </div>
                      </div>
                      <div class="bl0">
                        <div class="bl1">
                          <div class="bl2">
                            <div class="bl3">Translate site</div>
                            <div class="dle_b_website_translator" data-dlebid="34" data-dlebclicks="yes" ><div align="center"><div id="google_translate_element"></div><script type="text/javascript">
function googleTranslateElementInit() {
  new google.translate.TranslateElement({pageLanguage: 'ru', layout: google.translate.TranslateElement.InlineLayout.SIMPLE, autoDisplay: false}, 'google_translate_element');
}
</script><script type="text/javascript" src="//translate.google.com/translate_a/element.js?cb=googleTranslateElementInit"></script></div></div>
                          </div>
                        </div>
                      </div>
                      <div class="bl0">
                        <div class="bl1">
                          <div class="bl2">
                            <div class="bl3">Telegram канал</div>
                            <div align="center"><iframe src="https://tgwidget.com/widget/count/?id=5af5f76f83ba8872578b4567" frameborder="0" scrolling="no" horizontalscrolling="no" verticalscrolling="no" width="160px" height="50px" async></iframe></div>
                          </div>
                        </div>
                      </div>
                      <div class="bl0">
                        <div class="bl1">
                          <div class="bl2">
                            <div class="bl3">Реклама Google</div>
                            <div align="center"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Адаптивный1 -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-8258904172299765"
     data-ad-slot="4601517152"
     data-ad-format="auto"
     data-full-width-responsive="true"></ins>
<script>
    (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
                           </div>
                        </div>
                      </div>
                      <div class="bl0">
                        <div class="bl1">
                          <div class="bl2">
                            <div class="bl3">Поиск Google и Яндекс у нас</div>
                            
                            <div align="center">
    <div class="ya-site-form ya-site-form_inited_no" onclick="return {'action':'https://yandex.ru/search/site/','arrow':false,'bg':'transparent','fontsize':12,'fg':'#000000','language':'ru','logo':'rb','publicname':'Поиск по sergeistrelec.ru','suggest':true,'target':'_blank','tld':'ru','type':2,'usebigdictionary':true,'searchid':2271463,'input_fg':'#000000','input_bg':'#ffffff','input_fontStyle':'normal','input_fontWeight':'normal','input_placeholder':null,'input_placeholderColor':'#000000','input_borderColor':'#7f9db9'}"><form action="https://yandex.ru/search/site/" method="get" target="_blank"><input type="hidden" name="searchid" value="2271463"/><input type="hidden" name="l10n" value="ru"/><input type="hidden" name="reqenc" value=""/><input type="search" name="text" value=""/><input type="submit" value="Найти"/></form></div><style type="text/css">.ya-page_js_yes .ya-site-form_inited_no { display: none; }</style><script type="text/javascript">(function(w,d,c){var s=d.createElement('script'),h=d.getElementsByTagName('script')[0],e=d.documentElement;if((' '+e.className+' ').indexOf(' ya-page_js_yes ')===-1){e.className+=' ya-page_js_yes';}s.type='text/javascript';s.async=true;s.charset='utf-8';s.src=(d.location.protocol==='https:'?'https:':'http:')+'//site.yandex.net/v2.0/js/all.js';h.parentNode.insertBefore(s,h);(w[c]||(w[c]=[])).push(function(){Ya.Site.Form.init()})})(window,document,'yandex_site_callbacks');</script>
</div>
                          </div>
                        </div>
                      </div>
                      <div class="bl0">
                        <div class="bl1">
                          <div class="bl2">
                            <div class="bl3">Мои друзья / My friends</div>
                            
                            </div>
                        </div>
                      </div>
                      <div class="bl0">
                        <div class="bl1">
                          <div class="bl2">
                            <div class="bl3">Блок</div>
                           
                           </div>
                        </div>
                      </div>
                      <div class="bl0">
                        <div class="bl1">
                          <div class="bl2">
                            <div class="bl3">Поделиться с друзьями</div>
                            <div align="center"><script type="text/javascript">(function() {
  if (window.pluso)if (typeof window.pluso.start == "function") return;
  if (window.ifpluso==undefined) { window.ifpluso = 1;
    var d = document, s = d.createElement('script'), g = 'getElementsByTagName';
    s.type = 'text/javascript'; s.charset='UTF-8'; s.async = true;
    s.src = ('https:' == window.location.protocol ? 'https' : 'http')  + '://share.pluso.ru/pluso-like.js';
    var h=d[g]('body')[0];
    h.appendChild(s);
  }})();</script>
<div class="pluso" data-background="#ebebeb" data-options="medium,square,multiline,horizontal,counter,theme=04" data-services="vkontakte,odnoklassniki,facebook,twitter,google,moimir,yazakladki,moikrug,email,print"></div></div>
                          </div>
                        </div>
                      </div>
                      <div class="bl0">
                        <div class="bl1">
                          <div class="bl2">
                            <div class="bl3">Архив сайта</div>
                            
                          </div>
                        </div>
                      </div>
                    </div>
                    <!-- /RIGHT -->
                    <div id="center">
                                                       
                      <div id='dle-content'><div class="sh0">
   <div class="sh1">
      <div class="sh2">
         <div class="sh3">
            <div class="sh4">
               <div class="sh5">
                 <div class="sh6">
    		  <span id="news-title">Часто задаваемые вопросы / F.A.Q</span>
                 </div>
               </div>
             </div>
           </div>
         </div>
       </div>
     <div class="sh13">
       <style type="text/css">
    * {
        margin: 0;
        padding: 0;
    }
    
    .faq-container {
        color: #404040;
        /*font-family: Arial, sans-serif;*/
        font-size: 100%;
        height: 100%;
        line-height: 175%;
        margin: 0 16px;
        position: relative;
    }
    
    .faq-footer {
        height: 50px;
        padding: 36px 0;
        text-align: center;
    }
    
    .faq-header {
        padding: 12px 0;
        text-align: center;
    }
    
    .faq-header h1 {
        color: #cd5c5c;
        font-size: 171.4%;
    }
    
    .faq-language-markup {
        background-color: #fffaf0;
        border: 1px solid #b0c4de;
        border-radius: 3px;
        color: #000;
        font-family: Tahoma, Arial!important;
        margin: 8px 0;
        overflow: auto;
        padding: 10px;
    }
    
    .faq-last-edit {
        font-size: 87.5%;
        font-style: italic;
        text-align: right;
    }
    
    .faq-titles {
        color: #0069D6;
        cursor: pointer;
        text-decoration: underline;
    }
    
    .faq-titles:hover {
        color: red;
        cursor: pointer;
        text-decoration: none;
    }
    
    .faq-numbl {
        font-weight: 600;
        margin-right: 4px;
    }
    
    .faq-numbs {
        font-weight: 600;
        margin: 0 4px 0 9px;
    }
    
    .faq-pic {
        outline: 0;
    }
    
    .faq-spoiler-text {
        background-color: #f8f8ff;
        border: 1px solid #CCC;
        border-radius: 3px;
        margin: 5px 26px;
        padding: 5px 10px;
    }
    
    .faq-urls,
    .faq-urls:active,
    .faq-urls:visited {
        color: #0069D6 !important;
        text-decoration: underline !important;
    }
    
    .faq-urls:hover {
        color: #ff0000 !important;
        text-decoration: none !important;
    }

</style><div class="faq-container"><div class="faq-header"><div class="faq-last-edit">Версия: 25.05.2018</div><h1>Часто задаваемые вопросы / F.A.Q</h1><br><h3><span style="color:#ff0000;">Важно:</span> для редактирования конфигурационных (.cfg | .ini | .lst и.т.п.) а также командных (.cmd | .bat и.т.п.) файлов используйте <a class="faq-urls" href="http://akelpad.sourceforge.net/ru/index.php" target="_blank">AkelPad</a> или <a class="faq-urls" href="https://notepad-plus-plus.org/" target="_blank">Notepad++</a></h3></div><div class="faq-spoiler-wrapper"><!-- Begin FAQ --><div class="faq-spoiler faq-closed"><span class="faq-numbs">1.</span><span class="faq-titles">Зачем нужна ваша сборка и какова ее структура?</span></div><div class="faq-spoiler-text" style="display: none;">Сборка <b>Boot USB Sergei Strelec</b> - загрузочный диск для диагностики и обслуживания компьютеров, восстановления работоспособности ОС,<br>резервного копирования и восстановления данных, антивирусной профилактики.<br><br><b>Структура загрузочного образа:</b><br><br><img class="faq-pic fr-dii" src="http://www.sergeistrelec.ru/uploads/faq/root_dir.png" alt="Image"><br><br><b>EFI</b> - Каталог с загрузчиками, конфигурацией загрузки и другими файлами, необходимыми ТОЛЬКО для <a class="faq-urls" href="http://ru.osdev.wikia.com/wiki/UEFI">UEFI</a>.<br><b>rescue</b> - Каталог с файлами для Kaspersky Rescue Disk.<br><b>SSTR</b> - Главный каталог сборки.<br><b>bootmgr</b> - Mенеджер загрузки (не используется в <a class="faq-urls" href="http://ru.osdev.wikia.com/wiki/UEFI">UEFI</a>).<br><b>liveusb</b> - Компонент для Kaspersky Rescue Disk (файл-маркер).<br><br><b>Структура основного каталога сборки:</b><br><br><img class="faq-pic fr-dii" src="http://www.sergeistrelec.ru/uploads/faq/sstr_dir.png" alt="Image"><br><br><b>_WIN</b> - Каталог для установочных файлов/образов Windows<br><b>78Setup</b> - Специальная утилита для работы с каталогом _WIN<br><b>DOS</b> - Каталог с программами, работающими в среде MS-DOS (недоcтупно в режиме <a class="faq-urls" href="http://ru.osdev.wikia.com/wiki/UEFI">UEFI</a>)<br><b>DriverPacks</b> - Каталог с минимальным набором драйверов для WinPE<br><b>MInst</b> - Каталог с портативными приложениями и удобной программой-оболочкой для их запуска.<br><b>USER</b> - Каталог для пользовательских файлов(на данный момент поддерживаются только драйверы)<br><b>BCD</b> - Файл конфигурации для BOOTMGR (не используется в <a class="faq-urls" href="http://ru.osdev.wikia.com/wiki/UEFI">UEFI</a>)<br><b>boot.sdi</b> - Важный компонент загрузки (system deployment image)<br><b>bootmgr</b> - Файл-копия менеджера загрузки (не используется в <a class="faq-urls" href="http://ru.osdev.wikia.com/wiki/UEFI">UEFI</a>).<br><b>grldr</b> - Mенеджер загрузки "<a class="faq-urls" href="http://greenflash.su/Grub4Dos/Grub4dos.htm">Grub for Dos</a>" (не работает в <a class="faq-urls" href="http://ru.osdev.wikia.com/wiki/UEFI">UEFI</a>)<br><b>menu.lst</b> - Файл конфигурации для "<a class="faq-urls" href="http://greenflash.su/Grub4Dos/Grub4dos.htm">Grub for Dos</a>" (не используется в <a class="faq-urls" href="http://ru.osdev.wikia.com/wiki/UEFI">UEFI</a>)<br><b>strelec8NE.wim</b> - Микро-ядро Windows8 x86(только для Native режима)<br><b>strelec8.wim</b> - Ядро Windows8 x86<br><b>strelec10.wim</b> - Ядро Windows10 x86<br><b>strelec10x64.wim</b> - Ядро Windows10 x64</div><div class="faq-spoiler faq-closed"><span class="faq-numbs">2.</span><span class="faq-titles">Как лучше загружать вашу сборку: напрямую из файла-образа или распаковывать?</span></div><div class="faq-spoiler-text" style="display: none;">Рекомендуется загружать распакованную сборку, но окончательный выбор за вами(см. пункты <b>№3</b> и <b>№4</b>).</div><div class="faq-spoiler faq-closed"><span class="faq-numbs">3.</span><span class="faq-titles">Как добавить вашу сборку на загрузочную/мультизагрузочную флешку?</span></div><div class="faq-spoiler-text" style="display: none;"><b>Для мультизагрузочной флешки:</b><br>Если флешка на основе загрузчика <a class="faq-urls" href="http://greenflash.su/Grub4Dos/Grub4dos.htm" target="_blank">Grub4Dos</a>:<br><b>1.</b> Извлечь из образа каталог SSTR в "корень" флешки<br><b>2.</b> Добавить в файл MENU.LST следующее:<br><pre class="faq-language-markup"><code>title Boot USB Sergei Strelec 2014
find --set-root --ignore-floppies /SSTR/BOOTMGR
chainloader /SSTR/BOOTMGR</code></pre><b>Для загрузочной флешки:</b><br>Понадобится физически исправная флешки, объем от 4 до 32GB и формат файловой системы FAT32 можно считать вполне достаточными условиями.<br><b>1.</b> Открыть файл-образ сборки(iso) в программе UltraISO, перейти в меню "Самозагрузка" - Записать Образ Жесткого Диска" и записать загрузочную флешку.<br>Удалять или перемещать какие-либо файлы/каталоги в сборке, не имея понятия о структуре данной сборки и назначении этих самых файлов/каталогов - НЕ рекомендуется.</div><div class="faq-spoiler faq-closed"><span class="faq-numbs">4.</span><span class="faq-titles">Как загружать вашу сборку с флешки, но напрямую из файла-образа?</span></div><div class="faq-spoiler-text" style="display: none;">Понадобится исправная загрузочная флешка на основе загрузчика <a class="faq-urls" href="http://greenflash.su/Grub4Dos/Grub4dos.htm" target="_blank">Grub4Dos</a>.<br>Начиная с Boot USB Sergei Strelec 2014 v7.1 в сборку интегрирован FiraDisk Driver (File/RAM Disk driver for Windows), что позволяет без проблем загружать сборку напрямую с файла-образа.<br>Для этого в файл menu.lst на загрузочной флешке следует добавить следующее:<br><pre class="faq-language-markup"><code>#
iftitle [if exist /iso/strelec.iso] Boot Strelec 2014 from ISO
map --mem (md)+4 (99)
map /iso/strelec.iso (0xff)
map (hd0) (hd1)
map (hd1) (hd0)
map --hook
write (99) [FiraDisk]\nStartOptions=cdrom,vmem=find:/iso/strelec.iso;\n\0
chainloader (0xff)
#</code></pre>&nbsp;где "/iso/strelec.iso" это полный путь от корневого каталога загрузочной флешки до файла-образа сборки.<br>Атрибут "Read Only"(Только Чтение) у файла-образа(.iso) должен быть снят, не забываем проверить это.<br>Дефрагментация файла-образа обязательна, в противном случае образ сможет загрузиться только в RAM.<br>Для дефрагментации можно использовать, например, бесплатную программу <a class="faq-urls" href="https://www.piriform.com/defraggler" target="_blank" title="Defraggler">Defraggler</a></div><div class="faq-spoiler faq-closed"><span class="faq-numbs">5.</span><span class="faq-titles">Как загружать вашу сборку, если PC современный (UEFI) и вообще не поддерживает режим Legacy?</span></div><div class="faq-spoiler-text" style="display: none;">Все очень просто - загружайте х64 версию сборки, а загрузочная флешка должна быть отформатирована в FAT32 (см. пункт №8)</div><div class="faq-spoiler faq-closed"><span class="faq-numbs">6.</span><span class="faq-titles">Хочу обновить вашу сборку на флешке, как это сделать?</span></div><div class="faq-spoiler-text" style="display: none;">Просто удалите с флешки файлы сборки и распакуйте туда новые. Форматировать флешку не обязательно.</div><div class="faq-spoiler faq-closed"><span class="faq-numbs">7.</span><span class="faq-titles">Как создать "с нуля" загрузочную флешку и перепаковать встроенные программы?</span></div><div class="faq-spoiler-text" style="display: none;">Несколько устаревшее (в связи с появлением различных концептуальных программ) "видео-руководство" можно скачать <a class="faq-urls" href="http://rghost.ru/private/55023002/5a5e933a0d86cf848094efbdf2d90c7b" title="Ultimate Guide">здесь</a>.</div><div class="faq-spoiler faq-closed"><span class="faq-numbs">8.</span><span class="faq-titles">Какой программой лучше форматировать флешку?</span></div><div class="faq-spoiler-text" style="display: none;"><a class="faq-urls" href="https://www.google.com/search?q=HP+USB+Disk+Storage+Format+Tool+2.2.3&ie=utf-8&oe=utf-8" target="_blank">HP USB Disk Storage Format Tool 2.2.3</a></div><div class="faq-spoiler faq-closed"><span class="faq-numbs">9.</span><span class="faq-titles">Можно ли для создания загрузочной флешки использовать форматирование NTFS?</span></div><div class="faq-spoiler-text" style="display: none;">Да, можно. Но тогда загрузка PC в режиме <a class="faq-urls" href="http://ru.osdev.wikia.com/wiki/UEFI">UEFI</a> будет невозможна.<br><br><b>Инструкция:</b><br><b>1.</b> Форматируем флешку в NTFS, лучше программой HP USB Disk Storage Format Tool<br><b>2.</b> Запускаем программу BOOTICE 1.3.2 и внимательно смотрим, чтобы в поле "Destination Disk" отображалась флешка<br><b>3.</b> Нажимаем "Process MBR" и выставляем "UltralSO USB-HDD+", затем нажимаем "Install /Config"<br><b>4.</b> Нажимаем "Process PBR" и выставляем "BOOTMGR boot record", затем нажимаем "Install /Config"<br><b>5.</b> Нажимаем "Parts Manage", выделяем там нашу флешку и нажимаем Activate (т.е. делаем ее активной, иначе не загрузится)<br><b>6.</b> Распаковываем образ программой UltralSO в корневой каталог флешки и все, флешка готова - можно пробовать с нее загружаться.<br><br>Необходимый набор программ(без UltralSO) можно скачать <a class="faq-urls" href="http://rghost.ru/private/60497914/4b0fe7f13a83f24660063e92a0a32b71" target="_blank">здесь</a><br><br><p><img class="faq-pic fr-dii" src="http://picsee.net/upload/2014-11-02/307818588b2e.jpg" alt="Image"><img class="faq-pic fr-dii" src="http://picsee.net/upload/2014-11-02/3e77089a2b35.jpg" alt="Image"></p><p><img class="faq-pic fr-dii" src="http://picsee.net/upload/2014-11-02/c5cffecf969a.jpg" alt="Image"><img class="faq-pic fr-dii" src="http://picsee.net/upload/2014-11-02/ab90cceba582.jpg" alt="Image"></p><p><img class="faq-pic fr-dii" src="http://picsee.net/upload/2014-11-02/52f65a9dd96a.jpg" alt="Image"><img class="faq-pic fr-dii" src="http://picsee.net/upload/2014-11-02/ecc652d58af2.jpg" alt="Image"></p><p><img class="faq-pic fr-dii" src="http://picsee.net/upload/2014-11-02/5e7744c733e1.jpg" alt="Image"><img class="faq-pic fr-dii" src="http://picsee.net/upload/2014-11-02/cc34a7473f65.jpg" alt="Image"></p></div><div class="faq-spoiler faq-closed"><span class="faq-numbl">10.</span><span class="faq-titles">Как протеcтировать загрузку вашей сборки на VMware Workstation в режиме UEFI?</span></div><div class="faq-spoiler-text" style="display: none;">1. Создайте мастером новую чистую виртуальную машину (не включайте ее!)<br>2. Открыть в блокноте конфигурационный файл этой виртуальной машины (файл с расширением *.vmx) и в начале файла добавить строку&nbsp;<pre class="faq-language-markup"><code>firmware="efi"</code></pre><br>Конфигурационный файл искать в:&nbsp;<pre class="faq-language-markup"><code>%USERPROFILE%\Documents\Virtual Machines\%ИМЯ ВИРТУАЛЬНОЙ МАШИНЫ%\*.vmx</code></pre>&nbsp;Что в переводе на "человеко-понятный" звучит как: в каталоге "Мои Документы"</div><div class="faq-spoiler faq-closed"><span class="faq-numbl">11.</span><span class="faq-titles">Работает ли в режиме UEFI загрузчик Grub4Dos?</span></div><div class="faq-spoiler-text" style="display: none;">Нет, не работает.</div><div class="faq-spoiler faq-closed"><span class="faq-numbl">12.</span><span class="faq-titles">Ошибка в VirtualBox: "Нужно расширение физических возможностей для поддержки систем ОЗУ с 4Гб"</span></div><div class="faq-spoiler-text" style="display: none;">Нужно включить в настройках созданной виртуальной машины поддержку <a class="faq-urls" href="https://ru.wikipedia.org/wiki/PAE" target="_blank">PAE</a> (Расширение физических адресов)</div><div class="faq-spoiler faq-closed"><span class="faq-numbl">13.</span><span class="faq-titles">Как отредактировать загрузочное меню вашей сборки?</span></div><div class="faq-spoiler-text" style="display: none;">Загрузочное меню режима <a class="faq-urls" href="http://www.nastrojkabios.ru/parametri-zagruzki/boot-list-option.html" target="_blank">Legacy</a> находитcя в файле "SSTR\BCD".<br>Загрузочное меню режима <a class="faq-urls" href="http://ru.osdev.wikia.com/wiki/UEFI" target="_blank">UEFI</a> находитcя в файле "efi\microsoft\boot\BCD".<br>Редактируется с помощью утилит "BootIce v.1.3.2" или "Easy BCD". Обе утилиты присутствуют в составе сборки.</div><div class="faq-spoiler faq-closed"><span class="faq-numbl">14.</span><span class="faq-titles">Подходит ли ваша сборка для "древних" PC с объёмом RAM от 256mb и менее?</span></div><div class="faq-spoiler-text" style="display: none;">Нет, не подходит. Посмотрите в сторону сборок WinPE на базе WinXP/2003.</div><div class="faq-spoiler faq-closed"><span class="faq-numbl">15.</span><span class="faq-titles">Как загрузить вашу сборку на PC где CPU не поддерживает NX инструкции?</span></div><div class="faq-spoiler-text" style="display: none;"><b>Рекомендуется:</b> загрузить сборку в "Native Mode" (в загрузочном меню будет соответствующий пункт).</div><div class="faq-spoiler faq-closed"><span class="faq-numbl">16.</span><span class="faq-titles">Что такое "нативный" режим загрузки (Native Mode)?</span></div><div class="faq-spoiler-text" style="display: none;">Это специальный режим, в котором сначала загружается специально подготовленное минимальное ядро (без графической оболочки) и отрабатывает скрипт, который производит поиск носителя (DVD, USB-HDD) со сборкой и монтирует "полное" ядро.<br><br><span style="color:#32B232;">+Плюсы:</span><br><b>1.</b> Быстрая загрузка на USB 1.x. Вместо обычных 5-10 мин на USB 1.2 - около 1 минуты.<br><b>2.</b> Меньшее потребление памяти (для сборки Strelec - меньше на ~250Мб).<br><b>3.</b> Пониженные требования к CPU (ядро Native Mode пропатчено для работы с CPU начиная с P4/Athlon), отключена проверка NX-бита.<br><br><span style="color:#ff0000;">-Минусы:</span><br><b>1.</b> Привязка к носителю (при его извлечении - PC "зависнет").<br><b>2.</b> Более медленная работа ядра (поскольку всё загружается не из быстрого РАМ-диска, а c медленного носителя). На практике особых "тормозов" не ощущается.<br><b>3.</b> Некорректно работает RunScanner (утилита для перенаправления программ на работу с реестром целевой ОС), перенаправления на реестр целевой ОС не происходит.<br><b>4.</b> Для совместимости со старыми CPU отключена поддержка мультиядерности и РАЕ.<br><br><span style="color: green; font-weight: bold;">Примечание:</span> На современных PC лучше использовать обычный режим загрузки.</div><div class="faq-spoiler faq-closed"><span class="faq-numbl">17.</span><span class="faq-titles">Как установить Win8 на неразмеченный HDD в режиме UEFI + GPT с помощью WinNTSetup?</span></div><div class="faq-spoiler-text" style="display: none;"><b>1.</b> Переключаем режим загрузки PC <a class="faq-urls" href="http://www.nastrojkabios.ru/parametri-zagruzki/boot-list-option.html" target="_blank">из "Legacy" в "UEFI"</a> и грузим с флешки Boot_USB_Sergei_Strelec <b><span style="color: rgb(41, 105, 176);">x64</span></b><br><b>2.</b> Жмем WIN+R, вводим CMD затем DISKPART<br><b>3.</b> Вводим команду:&nbsp;<pre class="faq-language-markup"><code>list disk</code></pre>&nbsp;и получаем нумерованный список дисков. В данном примере целевой HDD имеет номер "0".<br><br><b>Далее выполняем рекомендации от</b> <a class="faq-urls" href="http://msdn.microsoft.com/ru-ru/library/hh825686.aspx" target="_blank" title="msdn.microsoft.com">msdn.microsoft.com</a> :<br><br><b>1.</b> Создаем на флешке текстовый файл с именем gpt.txt с таким содержанием:<br><pre class="faq-language-markup"><code>rem == CreatePartitions-UEFI.txt ==
rem == These commands are used with DiskPart to
rem create five partitions
rem for a UEFI/GPT-based PC.
rem Adjust the partition sizes to fill the drive
rem as necessary. ==
select disk 0
clean
convert gpt
rem == 1. Windows RE tools partition ===============
create partition primary size=300
format quick fs=ntfs label="Windows RE tools"
assign letter="T"
set id="de94bba4-06d1-4d40-a16a-bfd50179d6ac"
gpt attributes=0x8000000000000001
rem == 2. System partition =========================
create partition efi size=100
rem ** NOTE: For Advanced Format 4Kn drives,
rem change this value to size = 260 **
format quick fs=fat32 label="System"
assign letter="S"
rem == 3. Microsoft Reserved (MSR) partition =======
create partition msr size=128
rem == 4. Windows partition ========================
rem == Create the Windows partition ==========
create partition primary
rem == Create space for the recovery image ===
shrink minimum=15000
rem ** NOTE: Update this size to match the size
rem of the recovery image **
rem == Prepare the Windows partition =========
format quick fs=ntfs label="Windows"
assign letter="W"
rem === 5. Recovery image partition ================
create partition primary
format quick fs=ntfs label="Recovery image"
assign letter="R"
set id="de94bba4-06d1-4d40-a16a-bfd50179d6ac"
gpt attributes=0x8000000000000001
list volume
exit</code></pre>&nbsp;где в "<b>select disk 0</b>" - "0" это номер, полученный после команды "list disk" (у вас может быть другим!)<br><span style="color: rgb(255, 0, 0);"><b>Важно:</b></span> Если в PC установлено более одного HDD, то номер диска определяет: разметка какого-именно HDD будет изменена <b>с потерей</b> всех данных на нём.<br><br><b>2.</b> Запускаем консоль CMD и вводим:<br><pre class="faq-language-markup"><code>diskpart /s H:\gpt.txt</code></pre>&nbsp;Путь к файлу gpt.txt ес-но меняем на свой.<br>После отработки сценария раздел с label="Windows" можно разделить "по желанию" в любом <b>современном</b> менеджере разделов.<br><br>Теперь можно указать WinNTSetup на install.wim от win 8.*x64 или win 10.*x64<br>"Загрузчик" необходимо устанавливать на раздел с <b>label="System"</b>.<br>Операционную систему лучше устанавливать на первый раздел после раздела <b>MSR</b>(размер 128mb).<br>Перед началом установки WinNTSetup задаст вопрос о программе установки загрузчика и "по-умолчанию" предложит bootsect.exe. Принимаем это предложение.<br>Необходимо дождаться окончания подготовки файлов, о чем WinNTSetup сообщит и предложит перезагрузить PC.<br>После перезагрузки PC установка Windows начнется уже в "штатном" режиме.</div><div class="faq-spoiler faq-closed"><span class="faq-numbl">18.</span><span class="faq-titles">Ошибка Gimagex: "Opening WIM...please wait... ERROR: Unable to mount image."</span></div><div class="faq-spoiler-text" style="display: none;"><b>1.</b> Убедиться, что в системе включен показ "расширений" файлов (.xxx), если нет - включить.<br><b>2.</b> Создать текстовый файл clean.txt с содержимым:<br><pre class="faq-language-markup"><code>@echo off
for /f "tokens=1" %%i in ('tasklist ^| findstr /i "gimagex"') do (taskkill /f /im %%i &gt;nul)
:check
echo.
reg query "HKLM\SOFTWARE\Microsoft\WIMMount\Mounted Images" &gt;nul 2&gt;&amp;1
if errorlevel 1 (echo  MOUNTED IMAGES NOT FOUND!&amp;goto :exit)
echo  START CLEANUP ...
reg delete "HKLM\SOFTWARE\Microsoft\WIMMount\Mounted Images" /f &gt;nul 2&gt;&amp;1
:exit
echo.
pause</code></pre><b>3.</b> Переименовать файл "clean.txt" в "clean.cmd".<br><b>4.</b> Закрыть Gimagex и запустить "clean.cmd" от имени Администратора.<br><b>5.</b> Перезагрузить PC, удалить и создать заново каталог монтирования для wim-файла.</div><div class="faq-spoiler faq-closed"><span class="faq-numbl">19.</span><span class="faq-titles">Как в вашей сборке увеличить размер диска Boot(X:)?</span></div><div class="faq-spoiler-text" style="display: none;">Физическое ограничение для RAM-диска MicroSoft, используемого для создания диска X:\, составляет 512Мб (значение WinPECacheThreshold 200) для сборок на базе ХР/2003 и 1024Мб (WinPECacheThreshold 400) для 7-ки и выше. Большее значение можно установить (оно будет отображаться в свойствах X:\). Но реально при заполнении несжимаемыми данными (уточню - все внесенные данные на RAM-диск MicroSoft - сжимаются) более указанных размеров диск "переполняется" даже при достаточном количестве ОЗУ. Имхо, драйвер RAM-диска MicroSoft сделан очень рационально: даже если указать WinPECacheThreshold 400, то реальное потребление памяти при загрузке не увеличится, она будет потребляться только при заполнении диска (копировании туда данных/программ/драйверов). Причем (и это отличительная черта именно MicroSoft-вского драйвера!) при удалении добавленных данных задействованная под них память освобождается и возвращается системе. К примеру, ходовой ImDisk память в систему не возвращает, а Primo RAM disk возвращает, но не полностью.<br>Итог: под РЕ на базе 7-10 вполне можно указать WinPECacheThreshold 400 (и даже больше - хотя тут мало практической пользы), влияния на потребление памяти сборкой при запуске это не оказывает. Это значение нужно указать ДО загрузки, поскольку RAM-диск X:\ создается при запуске РЕ (т.е., значение должно быть указано в wim-ядре). Но, если памяти (ОЗУ) мало, то даже при незначительном заполнении данными X:\ туда нельзя будет записать что-либо (хотя циферку будет показывать "правильную" - мол, на X:\ места 1Гб). К примеру, на ПК с ОЗУ 1Гб при загрузке примерно 300Мб "отъест" само ядро, примерно 200-300 Мб занимает ОС в памяти плюс программный пакет (если он копируется на X:\) - ещё 200-300Мб. Т.е., под данные на RAM-диске остается очень мало, 100-200Мб. Если это понимать (что чудес не бывает, и нельзя при 1Гб ОЗУ сделать реальный размер RAM-диска больше свободной памяти - тот же 1Гб), то можно менять...<br><br><b>Применительно к сборке Boot CD USB Sergei Strelec на базе Windows 8.0:</b><br>Размер RAM диска устанавливается в реестре по пути&nbsp;<pre class="faq-language-markup"><code>[HKEY_LOCAL_MACHINE\System\ControlSet001\Services\FBWF]</code></pre><br><b>Параметр</b> "WinPECacheThreshold"<br>Если значение = 400, то это означает 1024Мб, значение = 300 означает 768Мб, значение = 200 означает 512Мб, значение = 100 означает 256Мб.<br>Если удалить вообще параметр "WinPECacheThreshold", то размер RAM диска будет 32МБ, то есть по умолчанию.<br><br><b>Применительно к сборке Boot CD USB Sergei Strelec на базе Windows 8.1:</b><br>Размер RAM диска определяется файлом fbwf.cfg расположенном в корне папки Windows, находящейся в ядре сборки (*.wim).<br>По умолчанию в моих сборках размер RAM диска х86 образа равен 512 МБ, х64 образа 1024 МБ.<br>Для изменения размера RAM диска, необходимо скачать архив <a class="faq-urls" href="https://sergeistrelec.ru/uploads/faq/sstr_fbwf.cfg.zip" target="_blank" title="sstr_fbwf.cfg.zip">sstr_fbwf.cfg.zip</a> и заменить<br>в ядре сборки файл "Windows\fbwf.cfg" на нужный вам файл из архива, предварительно преименовав этот файл в fbwf.cfg<br>Перепаковать ядро проще всего с помощью бесплатного архиватора 7zip версии не ниже 9.38b.<br>Так же для перепаковки ядра можно использовать программу Gimagex(несколько сложнее).<br><br><span style="color: green; font-weight: bold;">Примечание:</span> образы х86 не поддерживают размер RAM диска более 1024 МБ.</div><div class="faq-spoiler faq-closed"><span class="faq-numbl">20.</span><span class="faq-titles">Как в вашей сборке заменить обои на "Рабочем Столе" на собственные, но без изменения WIM-файла?</span></div><div class="faq-spoiler-text" style="display: none;"><b>Для сборок на базе Windows 8.0:</b><br>Начиная с v6.8 достаточно в папку SSTR\RESOURCES положить свои обои под названием wallpaper.jpg.<br><br><b>Для сборок на базе Windows 8.1-Windows 10:</b><br>В сборках на базе этих "ядер" механизм простой замены рисунка рабочего стола пока что не задействован, но несложный выход из этой ситуации есть.<br>С помощью архиватора <a class="faq-urls" href="http://www.7-zip.org/" title="http://www.7-zip.org/">7zip</a> версии от 16.xx и выше нужно открыть "ядра" (файлы "sterlec***.wim") как обычные архивы и заменить там файл "Windows\web\wallpaper\Windows\img0.jpg" на свой собственный рисунок, переименовав его в img0.jpg.</div><div class="faq-spoiler faq-closed"><span class="faq-numbl">21.</span><span class="faq-titles">Как загрузить вашу сборку если на PC не установлена Windows, нет Floppy и CD-DVD приводов и BIOS не поддерживает загрузку с флешки?</span></div><div class="faq-spoiler-text" style="display: none;"><b>Вариант №1:</b> Купить CD-DVD привод и загружать сборку с него (рекомендуется)<br><b>Вариант №2:</b> Подключить HDD на другой(полноценный) PC, починить/установить загрузчик, добавить возможность загружать сборку, вернуть HDD обратно.</div><div class="faq-spoiler faq-closed"><span class="faq-numbl">22.</span><span class="faq-titles">Как добавить к вашей сборке какой-нибудь дистрибутив Linux Live?</span></div><div class="faq-spoiler-text" style="display: none;">Рассмотрим решение вопроса на примере двух небольших дистрибутивов:<br><b>1.</b> <a class="faq-urls" href="http://runtu.org/" target="_blank">Runtu</a> (Русский)<br><b>2.</b> Parted Magic 2015.05.04 [x86/x64] (Английский)<br><br><b>Для Runtu:</b><br><b>1.</b> Перейти на сайт <a class="faq-urls" href="http://runtu.org/" target="_blank">Runtu</a> и скачать актуальный образ диска с дистрибутивом(обычно это iso-файл, <b>например:</b> runtu-xfce-14.04_20140514.iso)<br><b>2.</b> Создать в "корне" вашей загрузочной флешки каталог "linux", и каталог "runtu" внутри него.<br><b>3.</b> Открыть в "UltraIso" или "7zip" файл "runtu-xfce-14.04_20140514.iso", извлечь из находящегося там каталога "casper" в каталог "/linux/runtu"(на флешке) два файла: "vmlinuz" и "initrd.lz".<br><b>4.</b> Закрыть программы "UltraIso" или "7zip" (смотря чем открывали файл-образ).<br><b>5.</b> Скопировать на флешку в каталог "/linux/runtu" файл "runtu-xfce-14.04_20140514.iso" и переименовать его там в какое-нибудь более короткое имя, например: runtu1404.iso<br><b>6.</b> Перейти в каталог "SSTR" на флешке, открыть в "AkelPad" или "Notepad++" файл "menu.lst" и добавить туда следующее:<br><pre class="faq-language-markup"><code>iftitle [if exist /linux/runtu/runtu1404.iso] Boot Runtu 14.04
set d=linux/runtu
kernel /%d%/vmlinuz iso-scan/filename=/%d%/runtu1404.iso boot=casper nopersistent ignore_uuid locale=ru_RU.UTF-8 console-setup/layoutcode=ru noeject noprompt quiet splash --
initrd /%d%/initrd.lz
</code></pre><b>7.</b> Сохранить изменения, сделанные в файле "menu.lst" и можно пробовать загрузиться в Linux(пункт в меню: Boot Runtu 14.04 Live)<br><br><span style="color: green; font-weight: bold;">Примечание:</span> Данный способ загрузки позволяет загружать даже "фрагментированный" образ.<br><span style="font-weight: bold; color: rgb(0, 141, 0);">Полезный ресурс по теме:</span> <a class="faq-urls" href="http://greenflash.su/forum/6" target="_blank">http://greenflash.su/forum/6</a><br><br><b>Для Parted Magic:</b><br><b>1.</b> Cкачать актуальный образ диска с дистрибутивом(обычно это iso-файл, <b>например:</b> pmagic_2015_05_04.iso)<br><b>2.</b> Создать в "корне" вашей загрузочной флешки каталог "linux", и каталог "pmagic" внутри него.<br><b>3.</b> Скопировать на флешку в каталог "/linux/pmagic" файл "pmagic_2015_05_04.iso" и переименовать его там в какое-нибудь более простое имя, например: "parted_magic.iso"<br><b>4.</b> Перейти в каталог "SSTR" на флешке, открыть в "AkelPad" или "Notepad++" файл "menu.lst" и добавить туда следующее:<br><pre class="faq-language-markup"><code>iftitle [if exist /linux/pmagic/parted_magic.iso] Parted Magic Linux
find --set-root /SSTR/pmagic_linux.lst
configfile /SSTR/pmagic_linux.lst</code></pre><b>5.</b> Создать в каталогe "SSTR" на флешке новый текстовый документ, переименовать его в "pmagic_linux.lst", открыть его в "AkelPad" или "Notepad++" и добавить туда следующее:<br><pre class="faq-language-markup"><code>#
iftitle [if exist /linux/pmagic/parted_magic.iso] Parted Magic x86 (Runs from RAM, 1Gb+)
set d=linux/pmagic
map /%d%/Parted_Magic.iso (0xff)
map --hook
kernel (0xff)/pmagic/bzImage iso_filename=/%d%/Parted_Magic.iso edd=on vga=normal keymap=ru:-option~grp!ctrl_shift_toggle,grp_led!scroll~us,ru!:LatArCyrHeb-16
initrd (0xff)/pmagic/initrd.img (0xff)/pmagic/fu.img (0xff)/pmagic/m32.img
#
iftitle [if exist /linux/pmagic/parted_magic.iso] Parted Magic x64 (Runs from RAM, 1Gb+)
set d=linux/pmagic
map /%d%/Parted_Magic.iso (0xff)
map --hook
kernel (0xff)/pmagic/bzImage64 iso_filename=/%d%/Parted_Magic.iso edd=on vga=normal keymap=ru:-option~grp!ctrl_shift_toggle,grp_led!scroll~us,ru!:LatArCyrHeb-16
initrd (0xff)/pmagic/initrd.img (0xff)/pmagic/fu.img (0xff)/pmagic/m64.img
#
iftitle [if exist /linux/pmagic/parted_magic.iso] Parted Magic x86 (Live, 512Mb-1Gb)
set d=linux/pmagic
map /%d%/Parted_Magic.iso (0xff)
map --hook
kernel (0xff)/pmagic/bzImage iso_filename=/%d%/Parted_Magic.iso edd=on vga=normal boot=live eject=no vmalloc=512MiB keymap=ru:-option~grp!ctrl_shift_toggle,grp_led!scroll~us,ru!:LatArCyrHeb-16
initrd (0xff)/pmagic/initrd.img (0xff)/pmagic/fu.img (0xff)/pmagic/m32.img
#
iftitle [if exist /linux/pmagic/parted_magic.iso] Parted Magic x64 (Live, 512Mb-1Gb)
set d=linux/pmagic
map /%d%/Parted_Magic.iso (0xff)
map --hook
kernel (0xff)/pmagic/bzImage64 iso_filename=/%d%/Parted_Magic.iso edd=on vga=normal boot=live eject=no vmalloc=512MiB keymap=ru:-option~grp!ctrl_shift_toggle,grp_led!scroll~us,ru!:LatArCyrHeb-16
initrd (0xff)/pmagic/initrd.img (0xff)/pmagic/fu.img (0xff)/pmagic/m64.img
#
iftitle [if exist /linux/pmagic/parted_magic.iso] Parted Magic x86 (Failsafe)
set d=linux/pmagic
map /%d%/Parted_Magic.iso (0xff)
map --hook
kernel (0xff)/pmagic/bzImage iso_filename=/%d%/Parted_Magic.iso edd=on vga=normal vmalloc=512MiB acpi=off irqpoll noapic noapm nodma nomce nolapic nosmp nomodeset keymap=ru:-option~grp!ctrl_shift_toggle,grp_led!scroll~us,ru!:LatArCyrHeb-16
initrd (0xff)/pmagic/initrd.img (0xff)/pmagic/fu.img (0xff)/pmagic/m32.img
#
iftitle [if exist /linux/pmagic/parted_magic.iso] Parted Magic x64 (Failsafe)
set d=linux/pmagic
map /%d%/Parted_Magic.iso (0xff)
map --hook
kernel (0xff)/pmagic/bzImage64 iso_filename=/%d%/Parted_Magic.iso edd=on vga=normal vmalloc=512MiB acpi=off irqpoll noapic noapm nodma nomce nolapic nosmp nomodeset keymap=ru:-option~grp!ctrl_shift_toggle,grp_led!scroll~us,ru!:LatArCyrHeb-16
initrd (0xff)/pmagic/initrd.img (0xff)/pmagic/fu.img (0xff)/pmagic/m64.img
#
iftitle [if exist /linux/pmagic/parted_magic.iso] XVESA x32 (Alternate graphical server)
set d=linux/pmagic
map /%d%/Parted_Magic.iso (0xff)
map --hook
kernel (0xff)/pmagic/bzImage iso_filename=/%d%/Parted_Magic.iso edd=on vga=normal xvesa=yes vmalloc=512MiB keymap=ru:-option~grp!ctrl_shift_toggle,grp_led!scroll~us,ru!:LatArCyrHeb-16
initrd (0xff)/pmagic/initrd.img (0xff)/pmagic/fu.img (0xff)/pmagic/m32.img
#
iftitle [if exist /linux/pmagic/parted_magic.iso] XVESA x64 (Alternate graphical server)
set d=linux/pmagic
map /%d%/Parted_Magic.iso (0xff)
map --hook
kernel (0xff)/pmagic/bzImage64 iso_filename=/%d%/Parted_Magic.iso edd=on vga=normal xvesa=yes vmalloc=512MiB keymap=ru:-option~grp!ctrl_shift_toggle,grp_led!scroll~us,ru!:LatArCyrHeb-16
initrd (0xff)/pmagic/initrd.img (0xff)/pmagic/fu.img (0xff)/pmagic/m64.img
#
iftitle [if exist /linux/pmagic/parted_magic.iso] MHDD (HDD diagnostic and repair tool)
set d=linux/pmagic
map /%d%/Parted_Magic.iso (0xff)
map --hook
kernel (0xff)/boot/syslinux/memdisk iso_filename=/%d%/Parted_Magic.iso
initrd (0xff)/boot/mhdd/mhdd.gz
#
title [&lt;&lt; Main Menu]
find --set-root /SSTR/menu.lst
configfile /SSTR/menu.lst
#
</code></pre><br><span style="font-weight: bold; color: rgb(0, 141, 0);">Примечание:</span> Образ "Parted_Magic.iso" после копирования на флешку должен быть "дефрагментирован", иначе не загрузится.</div><div class="faq-spoiler faq-closed"><span class="faq-numbl">23.</span><span class="faq-titles">Как добавить в меню вашей основной сборки загрузку "Acronis Boot CD/USB Sergei Strelec"?</span></div><div class="faq-spoiler-text" style="display: none;">Рассмотрим решение на примере добавления Acronis Boot CD/USB Sergei Strelec (x64) в сборку Boot USB Sergei Strelec 2015 v.7.6<br>Добавлять будем на флешку объемом от 2(4) до 32gb включительно, размеченную в один раздел и отформатированную в FAT-32.<br><br><span style="font-weight: bold; color: rgb(0, 141, 0);">Примечания:</span><br><b>1.</b> Для Windows_10 работоспособность скрипта не проверялась и не гарантируется.<br><b>2.</b> Работа скрипта на ОС с языком , отличным от RU или ENG НЕ проверялась и НЕ гарантируется.<br><br><b>Порядок действий:</b><br><b>1.</b> Скачать образы "Boot USB Sergei Strelec 2015 v.7.6" и "Acronis Boot CD/USB Sergei Strelec (x64)"<br><b>2.</b> Записать образ "Boot USB Sergei Strelec 2015 v.7.6" на загрузочную флешку (рекомендуемым автором сборки способом) и проверить ее работоспособность.<br><b>3.</b> Если проверка прошла успешно, то открываем образ "Acronis Boot CD/USB Sergei Strelec (x64)" с пом. <a class="faq-urls" href="http://www.7-zip.org/download.html" target="_blank">7zip v16.xx</a> или UltraIso и извлекаем оттуда файл "acronis64.wim"<br>в каталог "\SSTR" недавно записанной загрузочной флешки.<br><b>4.</b> Меню "<b>Пуск</b>"<span style="color: blue; font-weight: bold;">-</span>"<b>Панель управления</b>"<span style="color: blue; font-weight: bold;">-</span>"<b>Параметры папок</b>"<span style="color: blue; font-weight: bold;">-</span>вкладка "<b>Вид</b>"<span style="color: blue; font-weight: bold;">-</span>поле "<b>Дополнительные параметры</b>"<span style="color: blue; font-weight: bold;">-</span>пункт "<b>Скрывать расширения для зарегистрированных типов файлов</b>"<br>Необходимо снять отметку с указанного пункта и нажать "<b>Ок</b>", с этого момента расширения файлов будут отображаться.<br><b>5.</b> Создать в корне загрузочной флешки текстовый файл, переименовать его <b>1.bat</b> и открыть его с помощью блокнота.<br><b>6.</b> Скопировать <b>КОД</b> в открытый "1.bat" и сохранить изменения.<br><b>7.</b> Запустить файл "1.bat" от имени Администратора и дождаться окончания его работы.<br><b>8.</b> Теперь Acronis Boot CD/USB Sergei Strelec (x64) будет доступен из загрузочного меню BOOTMGR (будет последним в списке)<br><b>9.</b> Т.к. файл "1.bat" больше не нужен, то его можно удалить с флешки .<br><br><b>Код для копирования в 1.bat:</b><br><pre class="faq-language-markup"><code>@echo off
REM ****************************************************
set MENU-ITEM="Acronis Boot CD/USB Sergei Strelec (x64)"
set PATH-TO-BCD="SSTR\BCD"
set PATH-TO-WIM="SSTR\acronis64.wim"
REM ****************************************************
cd /d "%~dp0"
cls &amp; echo.
set Bcdedit=%SYSTEMROOT%\System32\bcdedit.exe
if not exist %Bcdedit% (goto :wtf)
%Bcdedit% /store %PATH-TO-BCD% /create {ramdiskoptions}
%Bcdedit% /store %PATH-TO-BCD% /set {ramdiskoptions} ramdisksdidevice boot
%Bcdedit% /store %PATH-TO-BCD% /set {ramdiskoptions} ramdisksdipath \SSTR\boot.sdi
reg query "HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion" /v "CurrentVersion" | find "6.1" &gt;nul
if %errorlevel% EQU 0 (set /a OST=0) else (set /a OST=1)
%Bcdedit% /? /createstore | find /i "Example:" &gt;nul
if %errorlevel% EQU 0 (set /a VAL=3) else (set /a VAL=2)
for /F "tokens=%VAL%" %%i in ('%Bcdedit% /store %PATH-TO-BCD% /create /application osloader') do (
%Bcdedit% /store %PATH-TO-BCD% /set %%i description %MENU-ITEM%
%Bcdedit% /store %PATH-TO-BCD% /set %%i systemroot \Windows
%Bcdedit% /store %PATH-TO-BCD% /set %%i detecthal Yes
%Bcdedit% /store %PATH-TO-BCD% /set %%i winpe Yes
%Bcdedit% /store %PATH-TO-BCD% /set %%i osdevice ramdisk=[boot]\\%PATH-TO-WIM%,{ramdiskoptions}
%Bcdedit% /store %PATH-TO-BCD% /set %%i device ramdisk=[boot]\\%PATH-TO-WIM%,{ramdiskoptions}
%Bcdedit% /store %PATH-TO-BCD% /set %%i path \Windows\system32\boot\winload.exe
%Bcdedit% /store %PATH-TO-BCD% /set %%i locale ru-RU
%Bcdedit% /store %PATH-TO-BCD% /set %%i testsigning on
if %OST% EQU 1 (%Bcdedit% /store %PATH-TO-BCD% /set %%i bootmenupolicy Legacy)
%Bcdedit% /store %PATH-TO-BCD% /displayorder %%i /addlast
echo. &amp; echo GUID: %%i &amp; echo.
goto :exit
)
:wtf
cls &amp; echo. &amp; color 0C
echo  File: %SYSTEMROOT%\System32\bcdedit.exe NOT FOUND! &amp; echo.
:exit
pause
exit
</code></pre><br><span style="color: red; font-weight: bold;">Важно:</span> Для загрузки в режиме т.н "чистого" EFI (без Legacy) используется файл "\EFI\microsoft\boot\BCD" а не "\SSTR\BCD"<br><br><img class="faq-pic fr-dii" src="http://i064.radikal.ru/1501/54/97eaddfb1230.png" alt="Image"></div><div class="faq-spoiler faq-closed"><span class="faq-numbl">24.</span><span class="faq-titles">Как самостоятельно обновить программу SmartFix в вашей сборке?</span></div><div class="faq-spoiler-text" style="display: none;">Так как обновление сборки "Boot CD/USB Sergei Strelec" не всегда совпадает с выходом новой версии "SmartFix" - рекомендуется освоить следующие несложные шаги:<br><br><b>1.</b> Посетить <a class="faq-urls" href="https://smartfix.pro/">сайт разработчика</a> программы SmartFix и скачать файл "SmartFix.exe".<br><b>2.</b> Скачать актуальный образ сборки Boot USB Sergei Strelec и открыть его в программе UltraIso.<br><b>3.</b> Перейти в каталог "\SSTR\SmartFix", удалить "старый" файл SmartFix.exe и скопировать на его место "новую" версию файла.<br><b>4.</b> Перейти в меню "Файл" и выбрать пункт "Сохранить", дождаться окончания создания нового образа и закрыть UltraIso.<br><br>SmartFiх имеет встроенный механизм обновления. При старте программа проверяет в интернете наличие обновления и, если оно найдено - предлагает пррименить обновление. Если разрешить, то программа обновится автоматически.<br><b><span style="color: rgb(65, 168, 95);">Примечание:&nbsp;</span></b>Для тех, у кого сборка "Boot CD USB Sergei Strelec" уже распакована на флешку - достаточно выполнить пункт <b>№1</b> и затем <b>№3</b>(на флешке).</div><div class="faq-spoiler faq-closed"><span class="faq-numbl">25.</span><span class="faq-titles">Как добавить в вашу сборку возможность использования языка ввода и раскладки клавиатуры, отличных от Русского и Английского?</span></div><div class="faq-spoiler-text" style="display: none;">За это отвечают KBD**.dll-ки. Их можно взять в дистрибутиве Windows (в каталоге "\Windows\system32") и добавить в каталог "\Windows\system32" уже в ядре (*.wim) сборки.<br>Например если вам нужен украинский - добавляете KBDUR.DLL.<br>Затем можно создать командный файл ("My_Keyboard.cmd") с таким содержимым:<br><pre class="faq-language-markup"><code>@echo off &amp; wpeutil SetKeyboardLayout 0422:00000422 &amp; exit</code></pre>&nbsp;Затем необходимо скопировать этот файл в "корень" каталога "SSTR".<br>После загрузки в WinPE нужно перейти в каталог SSTR и запустить этот самый файл "My_Keyboard.cmd" и у вас появится украинская раскладка. И т.д.<br><br><img class="faq-pic fr-dii" src="http://picsee.net/upload/2015-05-24/e16ac8f2e42f.jpg" alt="Image"></div><div class="faq-spoiler faq-closed"><span class="faq-numbl">26.</span><span class="faq-titles">Как внести собственные изменения/дополнения в реестр вашей сборки?</span></div><div class="faq-spoiler-text" style="display: none;"><b>Загрузка куста реестра:</b><br><br>Чтобы загрузить или выгрузить куст реестра, используйте редактор реестра.<br>Команды Загрузить куст и Выгрузить куст применимы только к разделам "HKEY_USERS" и "HKEY_LOCAL_MACHINE" и активны <b>только тогда</b>, когда выбраны эти стандартные разделы.<br>При загрузке куста в реестр куст становится подразделом одного из этих разделов.<br><br><b>1.</b> Откройте редактор реестра ("Пуск"-&gt;Выполнить-&gt;regedit-&gt;"ОК")<br><b>2.</b> Выберите раздел "HKEY_USERS" или "HKEY_LOCAL_MACHINE".<br><b>3.</b> В меню Файл выберите команду "Загрузить куст".<br><b>4.</b> Выберите куст, который нужно загрузить.<br><b>5.</b> Нажмите кнопку "Открыть".<br><b>6.</b> В поле "Имя раздела" введите имя(произвольное), которое необходимо присвоить кусту, и нажмите "ОК".<br><b>7.</b> Внесите необходимые изменения в реестр.<br><br><b>Выгрузка куста реестра:</b><br><br><b>1.</b> Откройте редактор реестра ("Пуск"-&gt;Выполнить-&gt;regedit-&gt;"ОК")<br><b>2.</b> Выберите раздел "HKEY_USERS" или "HKEY_LOCAL_MACHINE".<br><b>3.</b> Выберите куст, ранее загруженный вами в систему.<br><b>4.</b> В меню Файл выберите команду "Выгрузить куст".<br><br><b>Применяем вышеуказанные рекомендации к сборке Boot CD USB Sergei Strelec:</b><br><br><b>1.</b> Извлечь (с помощью 7zip v16.xx) из "/SSTR/strelec8*.WIM" файл "\Windows\System32\config\SYSTEM" и загрузить его как куст реестра.<br><b>3.</b> Внести/добавить нужные вам значения в раздел "HKEY_USERS" или "HKEY_LOCAL_MACHINE" и выгрузить куст реестра.<br><b>4.</b> Заменить в сборке (с помощью 7zip v16.xx) в "/SSTR/strelec8*.WIM" файл "\Windows\System32\config\SYSTEM" на "выгруженный" вами файл "SYSTEM"<br><b>5.</b> Загрузить сборку на PC и проверить результат от внесенных вами изменений.<br><br><span style="color: green; font-weight: bold;">Примечание:</span> Оригинальные рекомендации от MS можно посмотреть <a class="faq-urls" href="https://technet.microsoft.com/ru-ru/library/cc732157.aspx" target="_blank">здесь</a>.</div><div class="faq-spoiler faq-closed"><span class="faq-numbl">27.</span><span class="faq-titles">Как можно сделать экспорт/импорт WLAN-профилей, чтобы не вводить данные каждый раз вручную?</span></div><div class="faq-spoiler-text" style="display: none;">Все сохраненные WLAN профили на компьютере хранятся в папке "ProgramData\Microsoft\Wlansvc\Profiles\Interfaces"<br>Ключ находится там как параметр keyMaterial в зашифрованном виде, выглядит как длинный набор букв и цифр.<br>Команда экспорта профиля выглядит так: netsh wlan export profile key=clear (key=clear расшифровывает ключ при экспорте)<br>Это стандартная команда от Microsoft для сохранения профилей, а затем их применения при переустановке ОС например,<br>чтоб не вводить все заново.<br>Поэтому "батник" должен выполнятся от имени Администратора, иначе ключ просто не расшифруется и работать не будет.<br>То есть в образ он должен быть помещен в расшифрованном виде, то есть его реальное значение,<br>иначе он правильно работать не будет. При импорте профиля он опять шифруется системой.<br><br><b>Автоматизация экспорта и импорта профилей:</b><br><br><b>1.</b> Включить показ расширений для зарегистрированных типов файлов.<br><b>2.</b> Создать папку с именем WLAN и в ней создать два текстовых файла: export.bat и import.bat<br><b>3.</b> Открыть в блокноте файл export.bat, скопировать код для export.bat и вставить его в открытый export.bat. Сохранить изменения в файле.<br><b>4.</b> Открыть в блокноте файл import.bat, скопировать код для import.bat и вставить его в открытый import.bat. Сохранить изменения в файле.<br><b>5.</b> Перенести папку WLAN на PC, с которого нужно экспортировать профили, перейти в нее и запустить с правами Администратора файл export.bat.<br><b>6.</b> В появившемся каталоге WLAN\_WLANProfiles должны будут появится XML-файлы с профилями, определите нужный вам профиль(или профили) и удалите не нужные.<br><b>7.</b> Перенести папку WLAN на PC, на который нужно экспортировать профили, перейти в нее и запустить с правами Администратора файл import.bat<br><b>8.</b> Если папка WLAN\_WLANProfiles более не нужна, то ее можно удалить.<br><br><b>Содержимое export.bat:</b><br><pre class="faq-language-markup"><code>@echo off
set wpdir=%~dp0_WLANProfiles
if not exist "%wpdir%" mkdir "%wpdir%"
netsh wlan export profile key=clear folder="%wpdir%"
cd /d "%wpdir%"
for /f "delims=" %%i in ('dir /a:-d /b') do (
for /f "delims=- tokens=2" %%j in ('echo %%i') do (
move /y "%%i" "%%j"
)
)
pause
exit</code></pre><br><b>Содержимое import.bat:</b><br><pre class="faq-language-markup"><code>@echo off
set wpdir=%~dp0_WLANProfiles
cd /d "%wpdir%"
for /f "delims=" %%i in ('dir /a:-d /b') do (
netsh wlan add profile filename="%%i" user=all
)
pause
exit
</code></pre></div><div class="faq-spoiler faq-closed"><span class="faq-numbl">28.</span><span class="faq-titles">Я нашел/написал по-моему потрясающую программу/скрипт. Как выложить ее на вашем сайте?</span></div><div class="faq-spoiler-text" style="display: none;"><b>1.</b> Сайт не является торрент-трекером (и.т.п), поэтому следует быть "умеренным в усердии своем".<br><b>2.</b> Нужно упаковать программу/скрипт + описание + "скриншоты" к ней в ZIP-архив и сохранить этот архив на один из (достойных по вашему мнению) <b>бесплатных</b> <a class="faq-urls" href="https://ru.wikipedia.org/wiki/%D0%A4%D0%B0%D0%B9%D0%BB%D0%BE%D0%BE%D0%B1%D0%BC%D0%B5%D0%BD%D0%BD%D0%B8%D0%BA">файлообменников</a>.<br><b>3.</b> Прислать ссылку на скачивание этого архива администрации форума. Если программа работоспособна, полезна и <b>соответствует тематике сайта</b> - тогда есть шанс, что она появится на сайте.<br><br><span style="color: green; font-weight: bold;">Примечание:</span> Степень полезности и соответствие тематике в данном случе определяется <b>не релизером или автором программы</b>, а администрацией сайта.</div><div class="faq-spoiler faq-closed"><span class="faq-numbl">29.</span><span class="faq-titles">Зачем нужны патчи-обновления для вашей сборки и как применять эти патчи?</span></div><div class="faq-spoiler-text" style="display: none;"><b>Общие сведения о патчах:</b><br>&nbsp;Для примера возьмем образ DVD-диска (~3.7Gb) с сложным программным обеспечением (П.O)<br>&nbsp;Разработчик регулярно вносит обновления или изменения в П.O и собирает обновленный образ для скачивания (~3.7Gb).<br>&nbsp;Зачастую "чистый" размер вносимых в П.О изменений может насчитывать от 100 до 500 мегабайт, а приходится скачивать весь образ (~3.7Gb).<br>&nbsp;Бывает, что тарифный план (или качество интернет-канала) оставляют желать лучшего, а потребность в актуальных обновлениях очень высока.<br>В таких случаях удобно обновляться Патчами.<br>&nbsp;Патчи изготавливают с помощью "Конструктора Патчей" - специальной программы, которая позволяет сравнить исходный и обновленный файлы,<br>&nbsp;извлечь из них <b>только&nbsp;</b>разницу и изготовить исполняемый файл, умеющий корректно добавить эту разницу в исходный файл.<br>&nbsp;Соответственно, размер скачиваемого обновления в 100 или пусть даже 500Mb ощутимо меньше 3.7Gb, что хорошо в случае с "плохим" интернетом.<br>&nbsp;Вместо скачивания "полноразмерного" файла можно своевременно скачивать только соответствующие Патчи и правильно применять их.<br>&nbsp;При таком подходе исходный (~3.7Gb) файл скачивается пользователем только один раз.<br><br><b>Основные типы патчей для сборки Boot USB Sergei Strelec</b><b>:</b><br><b>1.</b> Переходный патч - обычно нужен для обновления предыдущей версии сборки до следующей, например от v7.7 до v7.8<br><b>2.</b> Сплит(split) патч - выделяет из полной сборки только x86 или только х64 версию, дополнительно может содержать в себе те или иные неофициальные изменения для оригинальной сборки. Этот патч является "опцией" (необязательным) и не поддерживается автором сборки.<br><br><b>Применение переходного патча:</b><br><b>1.</b> Если патч был упакован в архив (.7z, .zip, .rar) - извлечь патч из архива в каталог с "старым" файлом-образом(.iso), к которому нужно применить патч.<br><b>2.</b> Запустить патч (на Windows 7-10 от имени Администратора).<br><b>3.</b> Дождаться окончания применения патча(будет сообщение).<br><b>4.</b> "Новый" образ будет находиться рядом со "старым" файлом-образом.<br><br><span style="color: green; font-weight: bold;">Примечания:</span><br><b>1.</b> Применение Сплит(split) патча полностью аналогично применению переходного патча.<br><b>2.</b> Рекомендуемый "Конструктор Патчей": <a class="faq-urls" href="https://files.fm/u/vr25qrxg">Mole's Smartversion Patch Constructor v2.2</a></div><div class="faq-spoiler faq-closed"><span class="faq-numbl">30.</span><span class="faq-titles">Как добавить в вашу сборку образ Kaspersky Rescue Disk 2018?</span></div><div class="faq-spoiler-text" style="display: none;"><b>Рекомендуемый способ:</b><br><b>1.</b> Скачать образ <a class="faq-urls" href="https://support.kaspersky.ru/viruses/krd2018#downloads" target="_blank">Kaspersky Rescue Disk 2018</a><br><b>2.</b> Создать каталог "Linux" в корне вашей загрузочной флешки и подкаталог "krd2018", т.е. должен получиться путь: "/Linux/krd2018"<br><b>3.</b> Открыть файл-образ "krd.iso" в программе "UltraISO" и извлечь всё содержимое образа на флешку в папку krd2018.<br><b>4.</b> Проверяем в файле "/SSTR/menu.lst" наличие нижеследующих строк - если их нет, то добавляем:<br><pre class="faq-language-markup"><code>iftitle [if exist  /Linux/krd2018/boot/grub/initrd.xz] Kaspersky Rescue Disk 2018
set _path= /Linux/krd2018
set lang=ru
# en=English; ru=Russian
set _kernel=k-x86_64
checkrange 0,1 is64bit &amp;&amp; set _kernel=k-x86
find --set-root %_path%/boot/grub/%_kernel%
kernel    %_path%/boot/grub/%_kernel% net.ifnames=0 lang=%lang% dostartx trace subdir=%_path%/data
initrd    %_path%/boot/grub/initrd.xz
boot</code></pre><span style="color:green;"><br><b>Примечания:</b></span><br><b>1.</b> Обновить версию Kaspersky Rescue Disk 2018 просто: удалить на флешке содержимое папки "krd2018" и извлечь туда содержимое нового образа.<br><b>2.</b> Способы загрузки с флешки Kaspersky Rescue Disk 2018 и Kaspersky Rescue Disk 10 совпадают, т.к. ЛК привела оба продукта к единой структуре образа.</div><div class="faq-spoiler faq-closed"><span class="faq-numbl">31.</span><span class="faq-titles">Как установить/переустановить Windows с помощью вашей сборки?</span></div><div class="faq-spoiler-text" style="display: none;">Рассмотрим самый простой и универсальный способ, который доступен любому, даже начинающему пользователю.<br><span style="color: red; font-weight: bold;">Нижеследующее руководство справедливо только для оригинальных дистрибутивов от Microsoft, модифицированные дистрибутивы Windows не рассматриваются - все вопросы к их авторам.</span><br><br><b>1.</b> Скопировать необходимый ISO-образ с системой на флешку. Туда же можно скопировать ключи для установки, если они требуются.<br><b>2.</b> Для установки х86(32х-битной) системы вам необходимо загрузиться с "WinPE-х86", а для установки х64(64х-битной) системы соответственно с "WinPE-х64"<br><b>3.</b> После загрузки WinPE вы можете предварительно подготовить HDD, создать, изменить разделы, протестировать диск, сделать бэкап предыдущей системы и т.д.<br><b>4.</b> Открываете в Проводнике флешку с ISO-образом(см. пункт №1), щелкаете по образу правой кнопкой мышки, и из контекстного меню выбираете: "Монтировать как ImDisk Virtual Disk".<br><b>5.</b> Двойной клик левой кнопкой мыши по значку "Мой компьютер" на "Рабочем столе" и в "Проводнике" должен быть виден смонтированный в виртуальный CD/DVD-привод образ.<br><b>6.</b> Открываете смонтированный образ как обыкновенную папку и запускаете файл "setup.exe".<br><b>7.</b> Производите стандартную установку Windows на нужный вам раздел или диск.<br><span style="color: green; font-weight: bold;">Примечания:</span><br><b>1.</b> Рекомендуется дополнительно форматировать раздел или диск, куда вы устанавливаете систему, прямо в программе установки (будет предложено установщиком на этапе подготовки диска).<br>Особенно если вы создавали или форматировали перед этим раздел/диск сторонними менеджерами разделов (Acronis DD и.т.п). Случается, что программа установки "не дружит" сторонней разметкой. Лучше лишний раз перестраховаться.</div><div class="faq-spoiler faq-closed"><span class="faq-numbl">32.</span><span class="faq-titles">Почему в режиме UEFI ваша сборка (x64) загружается, а (x86) не хочет, хотя на планшетах ситуация обратная?</span></div><div class="faq-spoiler-text" style="display: none;">В режиме UEFI версия WinPE должна соответствовать архитектуре компьютера.<br>На компьютерах в режиме UEFI на базе 64-разрядной архитектуры можно загрузить только 64-разрядные версии WinPE.<br>На компьютерах в режиме UEFI на базе 32-разрядной архитектуры можно загрузить только 32-разрядные версии WinPE.<br>Если компьютер поддерживает и режим UEFI, и прежний Legacy BIOS, то можно запустить 32-разрядную WinPE на 64-разрядном компьютере,<br>изменив в настройках BIOS режим "UEFI" на режим "Legacy BIOS" (ес-но, если эта возможность предусмотрена производителем PC).<br><br><a class="faq-urls" href="https://msdn.microsoft.com/en-us//library/Hh824898.aspx" target="_blank">Оригинал статьи на msdn.microsoft.com</a></div><div class="faq-spoiler faq-opened"><span class="faq-numbl">33.</span><span class="faq-titles">Как можно загружать Linux ISO образы?</span></div><div class="faq-spoiler-text" style="display: none;"><b>Инструкция от Сергея (sergeysvirid)</b><br>Извлеките содержимое этого архива на свою флешку со сборкой <a class="faq-urls" href="https://sergeistrelec.ru/uploads/files/Boot_images_from_the_Linux_folder.rar">Скачать</a><br>Закиньте свои линуксоподобные образы (*.iso) в папку <b>Linux</b><br>Что из себя представляет данный метод? В папку Linux можете поместить и загружать из неё свои образы,<br>такие как (.iso; .iz; .img; .ima; .vhd; .rhd; .bin; .fir; .wbl) различных LiveCD, антивирусных утилит и т.п.<br>Также из папки <b>Linux</b> имеется возможность загрузки архивов с расширением (.gz) и конфигфайлов с расширением (.lst)<br>Запуск этих образов производится из <b>Grub4Dos-меню</b> из пункта меню: "<b>Boot images from the Linux folder</b>"<br>При переходе по этому пункту будет создано меню загрузки образов.<br>При переходе по пункту меню: "<b>Запуск образов на базе ядра Linux</b>" не должен быть занят 4-й раздел первого диска.<br>(первый диск(hd0,0) в момент загрузки является тот, с которого Вы загрузились - то есть загрузочный раздел носителя)<br>Образ монтируется как (hd0,3).<br>Данный метод отлично подходит для загрузки образов на базе Linux.<br><b>!!!Имена файлов образов ДОЛЖНЫ быть английскими буквами и без пробелов!!! <br>!!!Образ (.iso) на загрузочном носителе должен быть <b>ОБЯЗАТЕЛЬНО дефрагментирован!!!</b><br>P.S. Если при запуске образа выскакивает ошибка <b>Error -60</b> - это означает, что Ваш [b]образ фрагментирован</b><br>и его <b>необходимо дефрагментировать</b> с помощью, например, программы <b>WinContig</b><br>Папка <b>Linux</b> может находиться на другом (отдельно от основной сборки) разделе того же диска.<br>Дублировать эту папку на двух разделах не нужно, а то будет найдена первая попавшаяся папка с именем <b>Linux</b> и будут искаться<br>образы в ней.<br><img class="faq-pic fr-dii" src="/uploads/screenshot/sergeysvirid.png" alt="Image"><br><img class="faq-pic fr-dii" src="/uploads/screenshot/sergeysvirid1.png" alt="Image"><br><img class="faq-pic fr-dii" src="/uploads/screenshot/sergeysvirid2.png" alt="Image"><br><img class="faq-pic fr-dii" src="/uploads/screenshot/sergeysvirid3.png" alt="Image"></div><!-- End FAQ --></div><!-- faq-wrapper --></div><!-- faq-container --><div class="faq-footer"><br></div><!-- <script type="text/javascript" src="https://code.jquery.com/jquery-1.4.1.min.js"></script> --> <script type="text/javascript">
    // <![CDATA[
    jQuery(document).ready(function() {
            jQuery('.faq-spoiler-text').hide()
            jQuery('.faq-spoiler').click(function() {
                jQuery(this).toggleClass("faq-closed").toggleClass("faq-opened").next().slideToggle(200)
            })
        })
        // ]]>

</script>								
         
     </div>
</div>
</div>                            
                    </div>
                  </div>
                </div>
              </div>
              <div class="clear"></div>
            </div>
          </div>
        </div>
        <div id="spacer"></div>
      </div>
    </div>
    <!-- FOOTER -->
    <div id="footer">
      <div class="f0">
        <div class="copyrights">
          © 2015-2020 Sergei Strelec
          <p><a href="/donate.html">Поддержать проект</a> | <a href="/index.php?do=feedback">Обратная связь | <a href="/index.php?action=mobile">Мобильная версия сайта</a></a></p>
        </div>
        <div class="slogan">..</div>
      </div>
      <div class="clear"></div>
      <ul class="footer-content">
        <li class="small-logo"></li>
        <li class="ads-f1"><!-- Yandex.Metrika informer -->
<a href="https://metrika.yandex.ru/stat/?id=33474613&amp;from=informer"
target="_blank" rel="nofollow"><img src="https://metrika-informer.com/informer/33474613/3_1_FFFFFFFF_EFEFEFFF_0_pageviews"
style="width:88px; height:31px; border:0;" alt="Яндекс.Метрика" title="Яндекс.Метрика: данные за сегодня (просмотры, визиты и уникальные посетители)" class="ym-advanced-informer" data-cid="33474613" data-lang="ru" /></a>
<!-- /Yandex.Metrika informer -->

<!-- Yandex.Metrika counter -->
<script type="text/javascript" >
    (function (d, w, c) {
        (w[c] = w[c] || []).push(function() {
            try {
                w.yaCounter33474613 = new Ya.Metrika({
                    id:33474613,
                    clickmap:true,
                    trackLinks:true,
                    accurateTrackBounce:true
                });
            } catch(e) { }
        });

        var n = d.getElementsByTagName("script")[0],
            s = d.createElement("script"),
            f = function () { n.parentNode.insertBefore(s, n); };
        s.type = "text/javascript";
        s.async = true;
        s.src = "https://cdn.jsdelivr.net/npm/yandex-metrica-watch/watch.js";

        if (w.opera == "[object Opera]") {
            d.addEventListener("DOMContentLoaded", f, false);
        } else { f(); }
    })(document, window, "yandex_metrika_callbacks");
</script>
<noscript><div><img src="https://mc.yandex.ru/watch/33474613" style="position:absolute; left:-9999px;" alt="" /></div></noscript>
<!-- /Yandex.Metrika counter --></li>
        <li class="ads-f2"></li>
        <li class="ads-f3"></li>
        <li class="ads-f4"><div class="dle_b_globalsign" data-dlebid="55" data-dlebclicks="yes" ><!--- DO NOT EDIT - GlobalSign SSL Site Seal Code - DO NOT EDIT ---><table width=125 border=0 cellspacing=0 cellpadding=0 title="CLICK TO VERIFY: This site uses a GlobalSign SSL Certificate to secure your personal information." ><tr><td><span id="ss_img_wrapper_gmogs_image_125-50_en_dblue"><a href="https://www.globalsign.com/" target=_blank title="GlobalSign Site Seal" rel="nofollow"><img alt="SSL" border=0 id="ss_img" src="//seal.globalsign.com/SiteSeal/images/gs_noscript_125-50_en.gif"></a></span><script type="text/javascript" src="//seal.globalsign.com/SiteSeal/gmogs_image_125-50_en_dblue.js"></script></td></tr></table><!--- DO NOT EDIT - GlobalSign SSL Site Seal Code - DO NOT EDIT ---></div></li>
      </ul>
      <div class="clear"></div>
    </div>
    <!-- /FOOTER -->
    <script>
   (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
   (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
    m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
    })(window,document,'script','//www.google-analytics.com/analytics.js','ga');
    ga('create', 'UA-37893678-2', 'auto');
    ga('send', 'pageview');
</script>
    <script type="text/javascript">
$(document).ready(function(){$('<div id="pageuserscroll"><ul><li><div class="page-top" title="Наверх">top</div></li><li><div class="page-up" title="Предыдущий экран">up</div></li><li><div class="page-down" title="Следующий экран">down</div></li><li><div class="page-bottom" title="Вниз">bottom</div></li></ul></div>').appendTo($('body'));if($(window).scrollTop()<200){$('#pageuserscroll .page-bottom, #pageuserscroll .page-down').fadeIn();}else{$('#pageuserscroll .page-up, #pageuserscroll .page-top').fadeIn();}
$('#pageuserscroll li div').click(function(){var currentScroll=$(document).scrollTop();if($(this).hasClass('page-top')){$('html, body').animate({scrollTop:$("body").offset().top},400);}
if($(this).hasClass('page-bottom')){$('html, body').animate({scrollTop:$(window).scrollTop()+$(document).height()},400);}
if($(this).hasClass('page-up')){$('html, body').animate({scrollTop:currentScroll-$(window).height()},400);}
if($(this).hasClass('page-down')){$('html, body').animate({scrollTop:currentScroll+$(window).height()},400);}});$(window).scroll(function(){if($(this).scrollTop()>=$(window).height()/ 2){$('#pageuserscroll .page-up, #pageuserscroll .page-top').fadeIn();}else{$('#pageuserscroll .page-up, #pageuserscroll .page-top').fadeOut();}
if($(this).scrollTop()>=$(document).height()-$(window).height()){$('#pageuserscroll .page-up, #pageuserscroll .page-top').fadeIn();$('#pageuserscroll .page-bottom, #pageuserscroll .page-down').fadeOut();}else if($(this).scrollTop()>=$(document).scrollTop()-($(window).height()/ 2)){$('#pageuserscroll .page-bottom, #pageuserscroll .page-down').fadeIn();}});});
</script>
    
  </body>
</html>
<!-- DataLife Engine Copyright SoftNews Media Group (http://dle-news.ru) -->
